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Analiza podataka
Preliminarna analiza podataka

Primeri
Pripremaǌe podataka za analizu

Analiza podataka obuhvata niz tehnika i metoda,
koje slu�e kao mo�ni alat za dobijaǌe znaqajnih
informacija iz podataka koji su dobijeni bilo iz
primarnih ili sekundarnih izvora podataka.

Kompletan istra�ivaqki projekat ukǉuquje:
pripremaǌe preliminarnog plana analize
podataka
pregled upitnika i validaciju podataka
editovaǌe (korigovaǌe)
kodiraǌe
preqix�avaǌe i tabeliraǌe podataka
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Pripremaǌe podataka za analizu

Kvalitet ulaznih podataka odre�uje kvalitet
informacija koje se dobijaju u postupku analize
podataka, a na osnovu kojih se donose odgovaraju�e
poslovne odluke.

Postupak pripremaǌa podataka za analizu:
1 Preliminarni plan analize podataka
2 Pregled upitnika i validacija podataka
3 Ure�ivaǌe podataka
4 Kodiraǌe podataka
5 Unos podataka
6 Preqix�avaǌe i statistiqko modifikovaǌe
podataka

7 Tabeliraǌe podataka
8 Selekcija strategije analiza podataka
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Pregled upitnika i validacija podataka

Provera prihvatǉivosti upitnika
nepotpuni delovi upinika
sistemski ili sluqajno preskoqena pitaǌa
neadekvatnost upitnika u smislu zadatkog tipa
uzorka
mala varijansa odgovora

Validacija podataka podrazumeva proveravaǌe
opservacija, upinika ili celokupnog ispitivaǌa.
Obuhvata:

1 skrining
2 procedura
3 potpunost
4 prevara
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Ure�ivaǌe (editovaǌe) podataka

Proveravaǌe podataka u smislu postojaǌa
grexaka, bilo da se radi o grexkama ispitivaqa
ili ispitanika. Problemi koji se mogu
identifikovati tokom ure�ivaǌa podataka:

grexke ispitivaqa
ispitanik nije odgovorio na pojedina pitaǌa
nejasan odgovor ispitanika
logiqki nekonzistentni odgovori
nevoǉnost ispitanika da odgovori na pitaǌa
neadekvantan ispitanik

Tretiraǌe nezadovoǉavaju�ih vrednosti
1 ponoviti kontakt na terenu
2 dodeǉivaǌe tretmana nedostaju�ih vrednosti
3 iskǉuqivaǌe ispitanika
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Xifrovaǌe (kodiraǌe) podataka

Dodeǉivaǌe odre�ene xifre svakom mogu�em
odgovoru na postavǉeno pitaǌe. Uslovi koji
moraju biti ispuǌeni:

uslov iskǉuqenosti kategorije odgovora moraju
biti me�usobno iskǉuqive

uslov potpunosti svaki odgovor na postavǉeno
pitaǌe mo�e da se dodeli odre�enoj
kategoriji
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Unos podataka

elektronski oblik
ostvaruje se prenosom kodiranih podataka iz
upitnika u raqunarski sistem
posebno pisani dokumenti - xifarnici
format radnih tabela (Excel , razni softverski
paketi)
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Preqix�avaǌe i statistiqka
modifikacija podataka

Preqix�avaǌe podataka se odnosi na proveru
konzistentnosti podataka i tretman nedostaju�ih vrednosti.
Provera konzistentnosti:

logiqka nekonzistentnost

vrednosti van dozvoǉenog intervala

ekstremne vrednosti

Tretman nedostaju�ih vrednosti:

zamena nedostaju�ih vrednosti nekom neutralnom
vrednox�u

brisaǌe opservacija

brisaǌe podataka samo za pojedinaqne promenǉive u
okviru posmatrane opservacije
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Preqix�avaǌe i statistiqka
modifikacija podataka

Statistiqko modifikovaǌe podataka mo�e se
vrxiti na razliqite naqine, a najqexi su:

ponderisaǌe podataka
prekodiraǌe podataka
transformacija podataka merenih na
razliqitim skalama mereǌa
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Tabeliraǌe podataka

Proces raqunaǌa broja opservacija koje pripadaju
odre�enoj kategoriji posmatranog obele�ja
(promenǉive).

jednostruko tabeliraǌe
unakrsno tabeliraǌe
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Izbor strategije analize podataka

Faktori koji utiqu na izbor strategije analize
podataka:

definisaǌe problema istra�ivaǌa, pristup
istra�ivaǌu i dizajn istra�ivaǌa

me�usobna (ne)zavisnost opservacija
broj grupa koje se posmatraju
broj mereǌa (promenǉivih) po jednom objektu
posmatraǌa u istra�ivaǌu
mogu�nost kontrole posmatranih promenǉivih

karakteristike podataka
osobine statistiqkih tehnika
pristup istra�ivaqa
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Karakteristike podataka - merne skale

nominalna 99K Nominal

ordinalna 99K Ordinal

intervalna 99K Scale

relaciona 99K Scale
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Nominalna skala

simbol oznaqava pripadnost objekta ili lica
odre�enoj grupi (kategoriji)
nije uvedena relacija poretka (nerangirane
kategorije)
definisana je samo relacija jednakosti
numeriqkog ili alfanumeriqkog tipa u SPSS−u

Primeri:
pol (0 =muxki, 1 =�enski), braqni status
(1 =o�eǌen/udata, 2 =neo�eǌen/neudata,
3 =razveden/razvedena, 4 =udovac/udovica, 5 =ostalo), boja
oqiju, poxtanski broj,...
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Ordinalna skala

kategoriqka promenǉiva sa definisanom
relacijom poretka (rangirane kategorije)
jedinica mere nije definisana (npr. 3 je ve�e
od 2, ali se ne zna intenzitet razlike)
intervali izme�u uzastopnih vrednosti ne
moraju biti isti (brojevi oznaqavaju samo
rangove)
preporuquje se da podaci budu numeriqkog tipa

Primeri:
ocene (1 =nedovoǉan, 2 =dovoǉan, 3 =dobar, 4 =vrlo dobar,
5 =odliqan), pozicija na rang listi (broj bodova izme�u
pozicija ne mora biti isti),...
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Intervalna skala

postoji poredak
intervali izme�u uzastopnih vrednosti su
jednaki
nula nema prirodno znaqeǌe, tj. ne predstavǉa
odsustvo posmatranog svojstva
ima smisla posmatrati razliku vrednosti, ali
ne i koloqnik
uvek numeriqkog tipa

Primeri:
standardizovani IQ testovi, temperatura vazduha (npr.,
12

◦ je toplije od 4
◦ za 8

◦, ali nije tri puta toplije jer 0
◦ ne

predstavǉa odsustvo temperature),...
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Racionalna skala

sve karakteristike kao intervalna skala uz
dodatak apsolutne nulte taqke
pore�eǌe dve vrednosti preko koliqnika
(pore�eǌe razliqitih mernih jedinica)
primena najve�eg broja statistiqkih tehnika
uvek numeriqkog tipa

Primeri:
temperatura u Kelvinima, visina, te�ina, primaǌa,
vreme qekaǌa na stanici,...

Marija Radiqevi� Statistiqki softver 4



Analiza podataka
Preliminarna analiza podataka

Primeri
Pripremaǌe podataka za analizu

Statistiqke tehnike

 

Статистичке 
технике

Технике анализе једне 
променљиве

Параметарске 
технике

Непараметарске 
технике

Мултивариационе 
технике

Технике 
зависности

Технике 
међузависности

Метрички подаци   Неметрички подаци   
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Parametarske tehnike

 

Параметарске 
технике

Један узорак:

t-тест

z-тест

Два или више узорака

Независни:

t-тест

z-тест

One-way ANOVA

Зависни:

Упарени  t-тест
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Neparametarske tehnike

 

Непараметарске 
технике

Један узорак:

Табела 
фреквенција

χ2 тест

K-S тест

Биномни

Тест корака

Два или више 
узорака

Независни узорци:

χ2 тест

Mann-Witney U тест

K-S тест

Тест медијане

K-W ANOVA 

Зависни узорци:

Тест знакова

Wikokson-ов тест

McNemar тест

Cochran Q тест

Friedman-ов тест
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Multivariacione tehnike

 

Мултивариаципне 
технике

Технике зависнпсти

Једна зависна 
прпменљива:

Унакрснп табелираое

ANOVA & ANCOVA

Вишеструка регресија

Дискриминаципна анализа

Conjoint анализа

Више зависних 
прпменљивих:

MANOVA & MANCOVA

Канпничка кпрелација

Вишеструка 
дискриминаципна анализа

Технике међузависнпсти

Фпкус на прпменљивима:

Фактпрка анализа

Фпкус на пбјектима:

Анализа груписаоа 

Вишедимензипналнп 
скалираое
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Merne skale i statistiqke tehnike
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Zaxto je va�no definisati merne skale
promenǉivih?

Da bi se primenile neke od statistika i
metoda u SPSS−u neophodno je da budu
definisane merne skale promenǉivih.
Qak i kada program ne zahteva definisaǌe
merne skale, to treba uqiniti da i se izbegla
eventualna nepravilna obrada podataka.
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Preliminarna analiza podataka

Procedure za sumarno prikazivaǌe podataka
Istra�ivaqka analiza podataka

Analyze⇒Descriptive Statistics
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Frequencies

tabela frekvencija za izabranu promenǉivu
niz statistiqkih deskriptivnih veliqina
dijagram

Tabela frekvencija sadr�i:
apsolutne frekvencije
procenat
validni procenat
kumulativni procenat
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Primer sa nedostaju�im vrednostima
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Descriptives

Variable - promenǉiva(e) neprekidnog tipa
Options - izbor statistike centralne
tendencije, disperzije, oblika raspodele i
redosleda prikazivaǌa rezultata
Save standardized values as variables - dobija se
nova promenǉiva sa standardizovanim
vrednostima
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Primer 1

Izabrati podniz zaposlenih koji imaju sadaxǌu
platu maǌu od 20000 i radni sta� ve�i od 5
godina, a zatim prikazati koliko ima takvih
zaposlenih po kategoriji posla. Koristiti bazu
baza.sav .

Data⇒ Select Cases

Analyze ⇒ Descriptive Statistics ⇒ Frequencies za
promenǉivu kat posla
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Primer 1

Izabrati podniz zaposlenih koji imaju sadaxǌu
platu maǌu od 20000 i radni sta� ve�i od 5
godina, a zatim prikazati koliko ima takvih
zaposlenih po kategoriji posla. Koristiti bazu
baza.sav .

Data⇒ Select Cases

Analyze ⇒ Descriptive Statistics ⇒ Frequencies za
promenǉivu kat posla
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Primer 2

Koliko ima zaposlenih qija se sadaxǌa plata
nalazi u intervalu [21000, 28000]? Koristiti bazu
baza.sav .

Transforme ⇒ Compute Variable funkcija
RANGE (splata, 21000, 28000)

Analyze ⇒ Descriptive Statistics ⇒ Frequencies
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Primer 2

Koliko ima zaposlenih qija se sadaxǌa plata
nalazi u intervalu [21000, 28000]? Koristiti bazu
baza.sav .

Transforme ⇒ Compute Variable funkcija
RANGE (splata, 21000, 28000)

Analyze ⇒ Descriptive Statistics ⇒ Frequencies
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Primer 3

Prikazati proseqnu starost 20% zaposlenih sa
najni�om sadaxǌom platom, kao i proseqnu
starost 20% zaposlenih sa najvixom sadaxǌom
platom. Koristiti bazu baza.sav .

Transforme ⇒ Visual Bining

Data⇒ Split File

Data⇒ Select Cases
If : sadasnjaPlata <= 1|sadasnjaPlata >= 5

Analyze ⇒ Descriptive Statistics ⇒ Descriptive za
promenǉivu starost
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Primeri

Primer 3

Prikazati proseqnu starost 20% zaposlenih sa
najni�om sadaxǌom platom, kao i proseqnu
starost 20% zaposlenih sa najvixom sadaxǌom
platom. Koristiti bazu baza.sav .

Transforme ⇒ Visual Bining

Data⇒ Split File

Data⇒ Select Cases
If : sadasnjaPlata <= 1|sadasnjaPlata >= 5

Analyze ⇒ Descriptive Statistics ⇒ Descriptive za
promenǉivu starost
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Napomena
Tra�ene dve grupe radnika se mogu formirati kroz
proceduru
Anayze ⇒ Descriptive Statistics ⇒ Frequencies ⇒ Statistics
u opciji Percentiles za promenǉivu splata.
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Primer 4

Primenom odgovaraju�ih procedura odgovoriti na
slede�a pitaǌa:
a) Da li �ene ili muxkarci u proseku koriste

internet vixe qasova nedeǉno?
b) Kod kog tipa internet korisnika su �ene

(odnosno muxkarci) najvixe zastupǉeni?
c) Prikazati proseqne vrednosti stava ispitanika

prema elektronskom marketingu, elektronskoj
trgovini i elektronskom bankarstvu. Uraditi
posebno za �ene i muxkarce.

d) Koliko qasova nedeǉno u proseku grupa vernih
korisnika koristi internet?

Koristiti bazu 2.
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a) Data⇒ Split File za promenǉivu pol , zatim
Anayze ⇒ Descriptive Statistics ⇒ Descriptives za
promenǉivu casovi .

b) Analyze ⇒ Descriptive Statistics ⇒ Frequencies za
promenǉivu Tip Internet korisnika.
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c) Analyze ⇒ Descriptive Statistics ⇒ Descriptive za promenǉive
el marketing , el tregovina, el bankarstvo.

c) Data⇒ Select Cases za uslov Tip Internet korisnika = 3 i
Anayze ⇒ Descriptive Statistics ⇒ Descriptive za promenǉivu
Casovi .
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Primer 5

Primenom odgovaraju�ih procedura odgovoriti na
slede�a pitaǌa:
a) U kojoj kategoriji posla ima najvixe (odnosno

najmaǌe) zaposlenih.
b) Prikazati proseqno radno iskustvo zaposlenih

za svaku kategoriju posla posebno.
c) Koliko procenata zaposlenih radi u prve dve

kategorije posla (prikazati posebno za
muxkarce i �ene)?

Koristiti bazu (baza.sav).
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a) Analyze⇒Descriptive Statistics⇒Frequencies za
promenǉivu kat_posla

b) Podeliti datoteku prema kategorijama posla:
Data⇒Split File, a zatim primeniti proceduru
Analyze⇒Desriptive Statistics⇒Descriptive za
promenǉivu r_staz

c) Podeliti datoteku prema polu: Data⇒Split File i
prikazati tabelu frekvencija za promenǉivu
kat_posla
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a) Analyze⇒Descriptive Statistics⇒Frequencies za
promenǉivu kat_posla

b) Podeliti datoteku prema kategorijama posla:
Data⇒Split File, a zatim primeniti proceduru
Analyze⇒Desriptive Statistics⇒Descriptive za
promenǉivu r_staz

c) Podeliti datoteku prema polu: Data⇒Split File i
prikazati tabelu frekvencija za promenǉivu
kat_posla
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a) Analyze⇒Descriptive Statistics⇒Frequencies za
promenǉivu kat_posla

b) Podeliti datoteku prema kategorijama posla:
Data⇒Split File, a zatim primeniti proceduru
Analyze⇒Desriptive Statistics⇒Descriptive za
promenǉivu r_staz

c) Podeliti datoteku prema polu: Data⇒Split File i
prikazati tabelu frekvencija za promenǉivu
kat_posla
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Hvala na pa�ǌi!
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